Patchwork [v6,03/11] vga-switcheroo: make PCI dependency explicit

login
register
mail settings
Submitter Sinan Kaya
Date Jan. 5, 2019, 10:05 a.m.
Message ID <20190105100606.6673-4-okaya@kernel.org>
Download mbox | patch
Permalink /patch/693299/
State New
Headers show

Comments

Sinan Kaya - Jan. 5, 2019, 10:05 a.m.
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.

Fixes: 5d32a66541c46 ("PCI/ACPI: Allow ACPI to be built without CONFIG_PCI set")
Signed-off-by: Sinan Kaya <okaya@kernel.org>
Reviewed-by: Lukas Wunner <lukas@wunner.de>
Acked-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
 drivers/gpu/vga/Kconfig | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/drivers/gpu/vga/Kconfig b/drivers/gpu/vga/Kconfig
index b677e5d524e6..d5f1d8e1c6f8 100644
--- a/drivers/gpu/vga/Kconfig
+++ b/drivers/gpu/vga/Kconfig
@@ -21,6 +21,7 @@  config VGA_SWITCHEROO
 	bool "Laptop Hybrid Graphics - GPU switching support"
 	depends on X86
 	depends on ACPI
+	depends on PCI
 	select VGA_ARB
 	help
 	  Many laptops released in 2008/9/10 have two GPUs with a multiplexer