Patchwork [v4,10/11] x86/intel/lpss: Make PCI dependency explicit

login
register
mail settings
Submitter Sinan Kaya
Date Dec. 30, 2018, 7:56 p.m.
Message ID <20181230195612.6657-11-okaya@kernel.org>
Download mbox | patch
Permalink /patch/691003/
State New
Headers show

Comments

Sinan Kaya - Dec. 30, 2018, 7:56 p.m.
LPSS code relies on PCI infrastructure but this dependency has not been
explicitly called out.

Fixes: 5d32a66541c46 ("PCI/ACPI: Allow ACPI to be built without CONFIG_PCI set")
Signed-off-by: Sinan Kaya <okaya@kernel.org>
---
 arch/x86/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index cc4f0c6ee1ed..322a58ababb0 100644
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -617,7 +617,7 @@  config X86_INTEL_QUARK
 
 config X86_INTEL_LPSS
 	bool "Intel Low Power Subsystem Support"
-	depends on X86 && ACPI
+	depends on X86 && ACPI && PCI
 	select COMMON_CLK
 	select PINCTRL
 	select IOSF_MBI