Patchwork dmaengine: fsl-qdma: add MODULE_LICENSE

login
register
mail settings
Submitter Arnd Bergmann
Date Dec. 10, 2018, 8:55 p.m.
Message ID <20181210205520.2956776-1-arnd@arndb.de>
Download mbox | patch
Permalink /patch/677385/
State New
Headers show

Comments

Arnd Bergmann - Dec. 10, 2018, 8:55 p.m.
The newly added driver lacks a MODULE_LICENSE tag, which now produces
a warning:

WARNING: modpost: missing MODULE_LICENSE() in drivers/dma/fsl-qdma.o

Add the license according to the SPDX specifier.

Fixes: 75628c149b0d ("dmaengine: fsl-qdma: Add qDMA controller driver for Layerscape SoCs")
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
 drivers/dma/fsl-qdma.c | 1 +
 1 file changed, 1 insertion(+)
Vinod Koul - Dec. 17, 2018, 6:16 a.m.
On 10-12-18, 21:55, Arnd Bergmann wrote:
> The newly added driver lacks a MODULE_LICENSE tag, which now produces
> a warning:
> 
> WARNING: modpost: missing MODULE_LICENSE() in drivers/dma/fsl-qdma.o
> 
> Add the license according to the SPDX specifier.

Applied, thanks

Patch

diff --git a/drivers/dma/fsl-qdma.c b/drivers/dma/fsl-qdma.c
index c18e3492090b..aa1d0ae3d207 100644
--- a/drivers/dma/fsl-qdma.c
+++ b/drivers/dma/fsl-qdma.c
@@ -1255,4 +1255,5 @@  static struct platform_driver fsl_qdma_driver = {
 module_platform_driver(fsl_qdma_driver);
 
 MODULE_ALIAS("platform:fsl-qdma");
+MODULE_LICENSE("GPL v2");
 MODULE_DESCRIPTION("NXP Layerscape qDMA engine driver");